Updated my node to 5.0.0 but now can't snyc

As the title says, I updated my node from version 3.0.1 to 5.0.0 today, and it is not synchronizing. It initially started to sync and it would not work. I rebooted my virtual server, tried again, and it successfully started to sync 300 blocks and updated 3 days worth, then stopped. I rebooted my virtual machine again, but it is still stuck. I am getting the following message in my terminal window…


The daemon will start synchronizing with the network. This may take a long time to complete.

You can set the level of process detailization through “set_log <level|categories>” command,
where is between 0 (no details) and 4 (very verbose), or custom category based levels (eg, *:WARNING).

Use the “help” command to see the list of available commands.
Use "help " to see a command’s documentation.


2019-12-28 15:00:25.614 [P2P1] WARN net.dns src/common/dns_utils.cpp:551 WARNING: no two val id SafexPulse DNS checkpoint records were received
2019-12-28 15:00:29.412 [P2P8] INFO global src/cryptonote_protocol/cryptonote_protocol_handler .inl:311 [142.93.171.239:17401 OUT] Sync data returned a new top block candidate: 331755 -> 347547 [Your node is 15792 blocks (21 days) behind]
SYNCHRONIZATION started
Couldn’t allocate RandomX cache

What does “Couldn’t allocate RandomX cache” mean? How can I resolve this?
I’ve been hosting a node for everyone since our mainnet started, and I’d like to keep up with it. Any help would be much appreciated.

-VR4

At first glance, how much memory do you have allocated to the virtual machine?

It could have to do with not having enough RAM

It is a basic Vultr account 512MB of ram, 20GB of storage, and running ubuntu 18.04. Same VS I setup over a year ago when mainnet first started.

EDIT:
I tried upgrading my VS ram from 512MB to 1024MB. Ran safexd again and it is synchronizing now. Thanks!

2 Likes

Thanks for reporting back that you got that resolved;